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INTRODUCTION 

Cancer continues to pose a significant challenge to 

global health, affecting millions of lives every year. 

Despite advances in conventional therapies, the 

development of resistance and unwanted side 

effects have prompted a growing interest in 

exploring alternative treatment strategies. The most 

common type of cancer on the list is Breast cancer 

with 3,00,590 new cases expected in US and third 

most prevalent cancer (14%) in India. (Uniyal, 

2023)
1
.
 
 Breast cancer primarily affects women, but 
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ABSTRACT 

Natural compounds with coumarin derivatives from selected natural sources hold potential as anti-cancer agents. 

Present study is designed to employ computational approaches such as molinspiration, Swiss ADME, pass 

analysis, Osiris property explorer and autodock to identify lead compounds in natural drugs containing the 

coumarin nucleus with specific activity against breast cancer which seems to time saving and cost effective. Pass 

analysis activity reported that angelicin was having less membrane integrated activity when compared to all other 

lead molecules. Osiris property explorer studies reported that angelicin was mutagenic, tumorigenic, and irritant; 

genistein was mutagenic, tumorigenic; kumatakenin and alpha mangostin were mutagenic whereas remaining 

lead molecules are safe. Docking studies reported that the binding score of hyperoside, naringenin, alpha 

mangostin, quercetin 3- O – α arabinopyranoside, kaempferol 3-O- α -d galactoside, genistein were lowest 

whereas remaining kumatakenin, eriodictyol hispidulin, luteolin 7- glucoside were highest in comparision with 

angelicin. 
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men can also develop breast cancer, although it is 

much less common (Gadag, Sinha, Nayak, Garg, 

Nayak, 2020)
2
. Breast cancer occurs when 

abnormal cells in the breast multiply and grow out 

of control, forming a tumor. These cancerous cells 

can invade nearby tissues and, in advanced stages, 

spread to other parts of the body through the 

lymphatic system or bloodstream. For the current 

study, a few natural drugs containing coumarin ring 

that possess anti-cancer activity have been selected 

as shown in the Table No.1
 
(Agnihotri, Wakode, 

2012
3
, Sree Nath, Khan, Ahmad 2014

4
, Levitsky, 

Dembitsky, 2015
5
). Natural compounds were often 

perceived as safer than synthetic compounds. The 

activity of these drugs was compared with a 

commercially available natural furanocoumarin 

agent called angelicin
 

(Acharya, Chacko, Bose, 

2019)
6
 that is used as adjuvant in treatment of 

Breast cancer. 

In-silico approaches 

Drug discovery and development is an intense, 

lengthy and interdisciplinary venture. There are 

many factors responsible for the failure of drugs, 

such as lack of effectiveness, side effects, poor 

pharmacokinetics and marketable reasons. A trend 

towards the use of insilico chemistry and molecular 

modelling for computer-aided drug design has 

gained significant momentum in recent times.  

Molinspiration 

Drug likeness is defined as a complex balance of 

various molecular properties and structural features 

that determine whether a particular molecule is like 

known drugs (Duffy, Devocelle, Shields, 2015)
7
. 

These properties include hydrophobicity, electronic 

distribution, hydrogen bonding characteristics, and 

flexibility. There are various rules such as 

Lipinski’s Rule of 5, Veber rule, Ghose rule, Ergan 

rule, Muegge rule, Opera rule of 3, Norinder rule of 

2, Monika rule, Veber rule describing the molecular 

properties that are important for the 

pharmacokinetics of the drugs.  

Swiss ADME 
The significance of the synthetic accessibility score 

is to determine the ease of synthesis of compounds 

and the scale ranges from 1 to 10. The value toward 

1 denotes that compound can be easily synthesized 

and the value approaching 10 denotes that it’s 

difficult to synthesize the compound. It is based on 

1024 fragmental contributions (FP 2) modulated by 

size and complexity penalties, trained on 12, 

782,590 molecules, and tested on 40 external 

molecules. 

PASS Analysis 

PASS Online predicts over 3500 kinds of biological 

activity, including pharmacological effects, 

mechanisms of action, toxic and adverse effects, 

interaction with metabolic enzymes and 

transporters, influence on gene expression, etc.  

OSIRIS Property explorer 

OSIRIS (Optical and Spectroscopic Information 

System) is a software tool used for predicting and 

evaluating the properties and behaviour of organic 

compounds. It is widely employed in the field of 

drug discovery and development to assess the drug-

likeness, toxicity and other key properties of 

chemical compounds.  

Auto Dock 

Auto Dock utilizes a grid-based energy evaluation 

approach combined with a search algorithm to 

explore the conformational space of the ligand 

within the receptor's binding site.  

 

METHODOLOGY 

Molinspiration 

Open the internet search engine (google/ explorer) 

and type www.molinspiration.com in the address 

bar. Then the home page of molinspiration will 

appear 

Select calculation of molecular properties and 

prediction of bioactivity. Enter the a) smiles 

notation of the chemical structure or b) draw the 

structure using given applet. Click on Calculate 

properties – to determine drug- likeness properties. 

Predict bioactivity- to determine binding affinity. 

Swiss ADME 
Open the internet search engine (google/ explorer) 

and type http://www.swissadme.ch in the address 

bar. Then home page of Swiss ADME will appear. 

Draw structure of the compound for which 

molecular properties to be determined in the left 



 

Soujanya Chaganti. et al. /Asian Journal of Research in Pharmaceutical Sciences and Biotechnology. 11(1), 2023, 1-11. 

Available online: www.uptodateresearchpublication.com         January – March                                       3 

 

side window (a) or enter smiles notation in the 

right-side window (b). Click on Run at the bottom 

of the page. 

PASS analysis  
Open the internet search engine (google/explorer) 

and type 

https://www.way2drug.com/PassOnline/predict.php

. Then the home page of pass analysis will appear 

where you should enter your email id for 

registration. Click on go for prediction where a 

interface appears to enter a password sent to your 

mail. Click on predict new compound. Select an 

option to enter molecule in the format of smiles/ 

MOL file/ Marvin JS (where you can draw 

molecule). Enter a molecule smiles notation (a) and 

click on get prediction (b). A page will open giving 

the (a) results of biological activity of the molecule 

Pa (probability of activity) and Pi (probability of 

inactivity). You can (b) get information about 

possible adverse effects. 

OSIRIS- Property Explorer 
Open the internet search engine (google/explorer) 

and type 

http://www.cheminfo.org/flavor/cheminformatics/U

tility/Property_explorer/index.html in the address 

bar 
26

. Then the home page of Osiris will appear. 

Click on the utility option and select property 

explorer. A page to draw the structure at the left 

side of the page will appear (a). After drawing the 

structure of the molecule predicted properties will 

appear. 

AutoDock 
Software required to be installed for Autodock: 

Autodock, MGLTools and Open Babel. 

The target protein was downloaded in PDB format 

from Protein Data Bank. 

The ligands were drawn in Chemsketch and saved 

in MOL/MDL format and converted to PDB format 

using Open Babel. 

To convert ligand to PDB format, select input 

format as MOLMDL → select ligand →select 

output format as PDB→ Convert. 

A docking folder was created with all the required 

files: autodock4.exe, autogrid4.exe, 

AD4.1_bound.dat, AD4 parameters.dat, ligand, and 

protein. 

Procedure for docking using AutoDock 

Open AutoDock → File → Preferences → Set → 

Startup Directory- copy and paste the docking 

folder pathway→ Set →Dismiss. 

Preparation of Protein 

I. All molecules (right click) → Read molecule → 

Select Protein →Open. 

II. To delete the extra chain of protein: Select ‘S’ 

for B chain →Edit → Delete →Delete selected 

Atoms→ Continue. 

III. Removal of water molecules: Edit → Delete 

water. 

IV. Add hydrogen: Edit →Hydrogens → Add → 

Polar only → Ok. 

V. Addition of Charges: Edit → Charges → Add 

Kollman charges → Ok. 

VI. Save protein in pdbqt format: Grid → 

Macromolecule → Choose → Select protein → 

Select molecule →Ok → add .pdbqt extension→ 

Save 

Preparation of Ligand 

I. Ligand →Input →Open → Select → ligand.pdb 

→ Open → Ok 

II. Ligand →Torsion tree →Choose root 

III. Ligand → Torsion tree → Detect root 

IV. Ligand → Output → add ‘.pdbqt’ extension → 

Save 

Grid-box generation  

I. Grid → Macromolecule →Choose →Protein (Ex: 

leqg) → Select molecule→ Ok 

II. Grid → Set map types → Choose ligand → 

ligand name→ Select ligand 

III. Grid → Grid box → Grid options→ ‘spacing’- 

increase to 1 Ả→ increase x, y, and z dimensions to 

fit the entire protein into the grid box 

IV. File → Close saving current. 

V.Grid → Grid box → File → Output grid 

dimensions file → Name as ‘grid.txt’ → Save 

VI. Grid → Output →Save GPF→ name the file 

with ‘gpf extension (ligand. gpf) → Save 

Docking 

I. Docking → Macromolecule → Set Rigid 

Filename →select protein → Open 
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II. Docking → Ligand → Choose→ ligand name → 

select ligand→ Accept 

III. Run → Run AutoGrid 

Program pathname → Browse → autogrid4 → 

Open. 

Parameter File name- Browse → ligand.gpf →Open 

→ Launch. 

IV. Docking→ Search parameters → Genetic 

Algorithm→ Accept. 

V. Docking →Docking parameters →Accept. 

VI. Docking → Output → Lamarckian → name file 

with .dpf extension (ligand.dpf) →Save. 

VII. Run → Run Autodock → Browse → Select 

AutoDock→ Open 

Program pathname→ Browse autodock4 → Open 

Parameter File name→ Browse → ligand.dpf → 

Open → Launch 

After docking was completed, the least binding 

energy and the corresponding conformation were 

noted from the DLG file. 

 

RESULTS AND DISCUSSION 

Physicochemical Properties 

According to Lipinski rule of five, the oral 

absorption of a drug is effective, when the 

following criteria is met: Molecular weight (MW) 

not more than 500 D, Hydrophobicity (log P) not 

more than 5, Number of hydrogen bond donors 

(HBD) not more than 5, Number of hydrogen bond 

acceptors(HBA) not more than 10. Any deviation 

from this rule will be notified as violation and gives 

indications for the possible structural modifications 

of the molecule so that it will evolve as the best fit 

to exhibit the desired pharmacological activity. 

From the Table No.2, it is reported that out of 

selected eleven, six compounds such as Angelicin, 

Hispidulin, Genistein, Kumatakenin, Naringenin, 

Eriodictyol, are in accordance with the Lipinski rule 

of five with zero violations whereas Alpha 

mangostin showing one violation with 6.32  log P 

value, Luteolin 7 glucoside, Hyperoside, 

Kaempferol -3-O-α-d- galactoside, Quercetin 3 o-

alpha- arabinopyranoside showing 2 violations with 

11, 12, 11, 11 hydrogen bond acceptor groups and 

7, 8, 7, 7, hydrogen bond donor groups respectively. 

Bioactivity 
Bioactivity is predicted by molinspiration; measure 

of the ability of the drug molecule to interact with 

different receptors such as GPCR ligands, Kinase 

inhibitors, Protease inhibitors, Ion channel 

modulators, or to interact with enzymes and nuclear 

receptors. Larger the bioactivity score, higher is the 

probability that the proposed molecules will be 

active. The compounds are considered to be active 

with a score more than 0.00, moderately active 

between -0.50 to 0.00 and inactive less than -0.50. 

From the Table No. 3, it is reported that all the 

selected compounds found to be more active 

towards nuclear receptor and enzymes compared to 

other elements. 

Swiss ADME 

Synthetic accessibility of the selected compounds 

was obtained using Swiss ADME open software 

which measures on a scale of 1 to 10; very easy to 

synthesise towards one and difficult towards ten. 

From table 4, it is inferred that Angelicin, 

Hispidulin, Genistein, Kumatakenin, Naringenin, 

Eriodictyol, Alpha mangostin  can be easily 

synthesised compared to Luteolin 7 glucoside, 

Hyperoside, Kaempferol -3-O-α-d- galactoside, 

Quercetin 3 o-alpha- arabinopyranoside.  

Pass Analysis Based on Membrane Integrated 

Agonistic Activity 

PASS analysis is predicted by 

(www.way2drug.com/passonline) software tools. 

PASS (Prediction of Activity Spectra for 

Substances) is used for evaluating the biological 

potential of the drug-like molecule. PASS provides 

contemporaneous prediction of many types of 

biological activity based on the structure of the 

proposed drug molecule. Thus, by performing PASS 

analysis one can predict the bioactivity profiles for 

proposed molecules before the chemical synthesis 

and biological testing. The probable bioactivity 

profiles for compounds under study can be 

predicted based on their structural formulae 

presented in MOLfile or SDfile format. PASS 

prediction is based on the knowledge base about 

structure-activity relationships for more than 

1,000,000 compounds with known biological 
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activities. Pa (probability "to be active") evaluates 

the probability that the proposed compound is 

active. Pi (probability "to be inactive") evaluates 

the probability that the proposed compound is 

inactive. 

Pa – atom promotes activity (Pa =1, Pi =0) 

Pi – atom promotes inactivity (Pa = 0, Pi =0) 

 It is identified that all the selected compounds have 

an impressive membrane integrated agonistic 

activity compared to angelicin as reported in the 

Table No.5. 

OSIRIS Property explorer 

The toxicity parameters calculated using OSIRIS 

were represented in the Table No.6. The results are 

represented with colour codes such as red, green 

and yellow. Green colour indicates the compounds 

with low toxicity, yellow indicates mild toxicity and 

red colour indicates high probability of toxicity. 

From table 6, it can be observed that all the 

compounds except Angelicin Genistein, 

Kumatakenin and Alpha mangostin are considered 

to be safe and are expected to show low or no 

toxicity in terms of mutagenicity, tumorigenicity, 

irritant effect and effect on reproductive system. 

Compounds like Angelicin, Genistein, 

Kumatakenin and Alpha mangostin possess the 

potential risk of mutagenicity while Angelicin, 

Genistein, shows tumerogenicity. Angelicin and 

Genistein might produce irritant and toxic effects 

on reproductive system respectively. The drug 

scores ranged from 0.11-0.88. The greater score 

was observed for Naringenin and the lowest was for 

Angelicin. The order of drug scores obtained were: 

Naringenin > Eriodictyol > Hispidulin > 

Hyperoside > Luteolin-7 glucoside > 

Kumatakenin> Kaempferol- 3-O-α-d- galactoside, 

Quercetin 3-o-alpha- arabinopyranoside> Alpha 

mangostin> Genistein> Angelicin. 

Green - Low toxicity; Yellow - Mild toxicity; Red - 

High toxicity. 

Binding Energies 

By using AutoDock, it is observed that Luteolin 7- 

glucoside and Kaempferol- 3-O-α-d- galactoside 

were having the highest and lowest values 

respectively when compared with the reference 

drug Angelicin which is a natural anticancer agent. 

Compounds with the lowest binding energy will 

show more affinity towards receptors, thus 

displaying more activity. Naringenin, Hyperoside, 

Genistein, Alpha mangostin, Quercetin3-o-alpha 

arabinopyranoside, and Kaempferol- 3-O-α-d- 

galactoside have less binding energy compared to 

the other natural products and reference drug; 

Angelicin as shown in the Table No.7. 

Discussion 

Molinspiration studies revealed various 

physicochemical properties and bioactivity scores 

of the selected set of compounds among which 

luteolin 7 – glucoside, hyperoside, kaempferol 3-O- 

α -d galactoside, alpha mangostin, quercetin 3- O – 

α arabinopyranoside were found to violate 

Linpinski’s rule of five(R05) in terms of number of 

hydrogen bond donors and acceptors. It was found 

that all lead molecules have greater affinity towards 

nuclear receptor ligand except angelicin. 

Swiss ADME studies revealed that angelicin, 

hispidulin, eriodictyol, kumatakenin, naringenin, 

genistein, alpha mangostin were easy to synthesize 

and remaining hyperoside, luteolin 7 – glucoside, 

kaempferol 3-O- α -d galactoside, quercetin 3- O – 

α arabinopyranoside were difficult to synthesize. 

Pass analysis activity reported that angelicin was 

having less membrane integrated activity when 

compared to all other lead molecules. 

Osiris property explorer studies reported that 

angelicin was mutagenic, tumorigenic, and irritant; 

genistein was mutagenic, tumorigenic; kumatakenin 

and alpha mangostin were mutagenic whereas 

remaining lead molecules are safe. 

Docking studies reported that the binding score of 

hyperoside, naringenin, alpha mangostin, quercetin 

3- O – α arabinopyranoside, kaempferol 3-O- α -d 

galactoside, genistein were lowest whereas 

remaining kumatakenin, eriodictyol hispidulin, 

luteolin 7- glucoside were highest in comparision 

with angelicin. 
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Table No.1: Various natural compounds containing coumarin nucleus selected for In-silico studies 

S.No Drug Structure Biological Source Family 

1 Angelicin 

 

Angelica 

archangelica 
Apiaceae 

2 Hispidulin 

 

Eupatorium 

arnottianum 
Asteraceae 

3 
Luteolin,7- 

glucoside 

 

Achillea 

millefolium 
Asteraceae 

4 Genistein 

 

Glycine max Fabaceae 

5 Kumatakenin 

 

Chrysanthemum 

morifolium 
Asteraceae 

6 Naringenin 

 

Citrus paradisi Rutaceae 

7 Hyperoside 

 

Eupatorium 

arnottianum 
Asteraceae 
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8 Eriodictyol 

 

Eupatorium 

arnottianum 
Asteraceae 

9 
Kaempferol-3,O-

alpha-galactoside 

 

Calluna vulgaris Ericaceae 

10 Alpha mangostin 

 

Garcinia 

mangostana 
Guttiferae 

11 

Quercetin 3 o-

alpha-

arabinopyranoside 
 

Geranium pratense Geraniaceae 

Table No.2: Physicochemical properties of the selected compounds by using molinspiration 

S.No Drug miLogp TPSA natoms MW nOH nOHNH nviolations nrotb volume 

1 Angelicin 2.29 43.35 14 186.17 3 0 0 0 154.15 

2 Hispidulin 2.48 100.13 22 300.27 6 3 0 2 249.59 

3 
Luteolin, 7- 

glucoside 
0.19 190.28 32 448.38 11 7 2 4 364.19 

4 Genistein 2.27 90.89 20 270.24 5 3 0 1 224.05 

5 Kumatakenin 2.98 89.14 23 314.29 6 2 0 3 267.12 

6 Naringenin 2.12 86.99 20 272.26 5 3 0 1 230.26 

7 Hyperoside -0.36 210.5 33 464.38 12 8 2 4 372.21 

8 Eriodictyol 1.63 107.22 21 288.25 6 4 0 1 238.28 

9 
Kaempferol -3-O-

α-d- galactoside 
0.12 190.28 32 448.38 11 7 2 4 364.19 

10 Alpha mangostin 6.32 100.13 30 410.47 6 3 1 5 376.86 

11 

Quercetin 3 o-

alpha-

arabinopyranoside 
0.80 190.28 31 434.35 11 7 2 4 347.36 
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Table No.3: Bioactivity scores of selected compounds using molinspiration 

S.No Drug 
GPCR 

ligand 

Ion channel 

modulator 

Kinase 

inhibitor 

Nuclear 

receptor ligand 

Protease 

inhibitor 

Enzyme 

inhibitor 

1 Angelicin -0.87 -0.48 -0.88 -0.93 -1.15 -0.28 

2 Hispidulin -0.07 -0.22 0.21 0.20 -0.33 0.17 

3 
Luteolin,7- 

galactoside 
0.09 -0.02 0.15 0.27 -0.01 0.42 

4 Genistein -0.22 -0.54 -0.06 0.23 -0.68 0.13 

5 Kumatakenin -0.10 -0.21 0.13 0.22 -0.26 0.17 

6 Naringenin 0.03 -0.20 -0.26 0.42 -0.12 0.21 

7 Hyperoside 0.06 -0.04 0.13 0.20 -0.06 0.42 

8 Eriodictyol 0.07 -0.20 -0.22 0.46 -0.09 0.21 

9 
Kaempferol- 3-O-α-

d- galactoside 
0.06 -0.05 0.10 0.20 -0.05 0.41 

10 Alpha mangostin -0.01 -0.12 -0.10 0.45 -0.19 0.39 

11 
Quercetin 3-o-alpha-

arabinopyranoside 
0.20 -0.04 0.21 0.06 -0.01 0.53 

Table No.4: Synthetic accessibility score of the selected compounds by using Swiss ADME 

Table No.5: Pa and Pi score of the selected compounds by using Pass analysis 

S.No Drug Pa Pi Other activities 

1 Angelicin 0.623 0.069 
CYP2A 11 substrate, antimutagenic, oxidoreductase 

inhibitor, photosensitizer 

2 Hispidulin 0.945 0.004 
Kinase inhibitor, chlordecone reductase inhibitor, 

Aldehyde oxidase inhibitor 

3 Luteolin-7-glucoside 0.975 0.001 
Hemostatic , Vaso protector, Membrane permeability 

inhibitor 

4 Genistein 0.913 0.008 
HIF 1 A expression inhibitor, chlordecone reductase 

inhibitor, CYP 1 A substrate 

5 Kumatakenin 0.976 0.002 
Chlordecone reductase inhibitor, Antimutagenic, 

CYP1A inhibitor 

6 Naringenin 0.964 0.003 
HMOX 1 expression enhancer, CYP1 A substrate, 

chlordecone reductase inhibitor 

S.No Drug Synthesis accessibility 

1 Angelicin 3.07 

2 Hispidulin 3.12 

3 Luteolin 7- glucoside 5.17 

4 Genistein 2.87 

5 Kumatakenin 3.34 

6 Naringenin 3.01 

7 Hyperoside 5.32 

8 Eriodictyol 3.11 

9 Kaempferol- 3-O-α-d- galactoside 5.29 

10 Alpha mangostin 3.91 

11 Quercetin 3-o-alpha- arabinopyranoside 5.04 
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7 Hyperoside 0.989 0.001 
Hemostatic, cardio protectant, Monophenol 

monooxygenase inhibitor 

8 Eriodictyol 0.962 0.002 
UGT 1A 10 substrate, CYP 1A substrate, chlordecone 

reductase inhibitor 

9 
Kaempferol- 3-O-α-d- 

galactoside 
0.989 0.001 

Hemostatic, Cardio protectant, 

Membrane permeability inhibitor 

10 Alpha mangostin 0.950 0.004 
Apoptosis  agonist, UGT 1A9 substrate, Lipid 

peroxidase inhibitor 

11 
Quercetin 3 O- Alpha 

Arabinopyranoside 
0.980 0.001 

Monophenol Monooxygenase Inhibitor, Membrane 

Permeability Inhibitor, Free Radical Scavenger 

Table No.6: Toxicity profile of the selected compounds 

S.No Drug Mutagenic Tumorigenic Irritant 
Reproductive      

Effective 

Drug 

likeness 

Drug-

Score 

1 Angelicin red red red green -3.14 0.11 

2 Hispidulin green green green green 1.11 0.81 

3 
Luteolin-7 

glucoside 
green green green green 0.76 0.69 

4 Genistein red red green red 1.16 0.18 

5 Kumatakenin red green green green 0.89 0.47 

6 Naringenin green green green green 1.90 0.88 

7 Hyperoside green green green green 1.58 0.72 

8 Eriodictyol green green green green 1.49 0.86 

9 
Kaempferol- 3-O-

α-d- galactoside 
green green green green -2.43 0.44 

10 Alpha mangostin red green green green -1.11 0.20 

11 
Quercetin 3-o-

alpha- 

arabinopyranoside 

green green green green -2.58 0.44 

Table No.7: Binding energies of the selected compounds using Autodock 

S.No DRUG Binding Energy 

1 Angelicin -5.33 

2 Luteolin 7- glucoside -3.66 

3 Hispidulin -4.86 

4 Eriodictyol -4.96 

5 Kumatakenin -5.03 

6 Naringenin -5.71 

7 Hyperoside -5.77 

8 Genistein -5.95 

9 Alpha mangostin -6.64 

10 Quercetin 3-o-alpha- arabinopyranoside -7.20 

11 Kaempferol- 3-O-α-d- galactoside -8.32 

 

 

 

 



 

Soujanya Chaganti. et al. /Asian Journal of Research in Pharmaceutical Sciences and Biotechnology. 11(1), 2023, 1-11. 

Available online: www.uptodateresearchpublication.com         January – March                                       10 

 

CONCLUSION 
Various computational approaches have been 

employed to derive several parameters like 

physicochemical properties, bioactivity scores, 

synthetic accessibility, membrane integrated 

activity, toxicity profile and binding score with a 

selected set of coumarin rings containing natural 

anticancer agents. This study provided the basis for 

the selection of compounds to carry out synthesis 

and pharmacological activity studies on the selected 

compounds. 
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